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Step-By-Step EXERCISE 1 
Defi ne Data Needs
When you begin to design a database, you should think about the types of data that 

you need to include. One way to prepare data use in a database is to set up your data 

fi elds in a spreadsheet program such as Microsoft Excel. When entering data in an 

Access database, consider whether the data should be calculated by the database or 

entered by the user. Stored data will remain the same until the user manually changes 

it. Calculated data changes in response to other data modifi cations. Examples of 

stored data and calculated data are shown in Table 1.1.

TABLE 1.1 Examples of stored data and calculated data

Stored Data Calculated Data

Product ID Total value of all products in inventory.

Product name Total number of products in inventory.

Product cost
Total Value is calculated by multiplying the Product cost fi eld by the 
Inventory fi eld. 

Inventory Average monthly inventory levels.

FIGURE 1.1 Product Info worksheet

Examples of fields 
with stored data

Field with 
calculated data

Cell E2

Records

 Choose Start>All 

Programs>Microsoft 

Office®>Microsoft Office 

Excel 2007.

 In Excel, click Office . 

Click Open.

 Locate and open the data 

fi le Product Info.xlsx. 

Save as: Product Info-[your 

first initial and last name] 

(for example, Product Info-

rgupta). 

 Read each fi eld name. Note 

that the fi elds Product ID, 

Product Name, Cost, 

and Inventory all contain 

stored data.

 Click in cell E2 in the Total 

Value fi eld (see Figure 1.1). 

 Your screen 

should look like Figure 1.1.

Continued on the next page.

If a database stores cus-
tomer address information, 
the data remains the same 
until a user goes into the 
database and changes it. 
If the database tracks the 
total value of a product, the 
value in inventory changes 
when the price changes.
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Step-By-Step EXERCISE 1 (Continued)

Defi ne Data Needs

FIGURE 1.2 Stored data in Product Info worksheet

FIGURE 1.3 Calculated data changed

Change in cell D2 causes 
calculated value in cell E2 
to change

 Click in cell D2 (see 

Figure 1.2).

 Select 1000. Key: 500. 

Press . 

 Your screen 

should look like Figure 1.3. 

Note that the value in cell 

E2 changes to $132,600.

 Save and close the 

Product Info spreadsheet 

and exit Excel.

Continue to the next exercise.

Stored data, such as the 
price of a inventory in an 
automotive parts ware-
house database, must be 
changed manually. Calcu-
lated data depends on 
other data. For example, 
the total value of all gaskets 
held in the ware house’s 
inventory would change if 
either the price of head 
gaskets went up or the 
quantity of gaskets went 
up or down. You can calcu-
late stored data in Excel 
and import it to Access. 
You also can create 
calculated and stored 
data directly in Access.
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Step-By-Step EXERCISE 2
Defi ne Field Data Types
You can use various data types to organize the data in your database. Some data is 

best presented as text, while other data should appear as a number. Sometimes, data 

should be stored as a combination of both, or as one of two values, such as Yes or No. 

A Memo data type, which can store up to 65,535 characters, is best for storing long 

text data, such as a comment or note about a particular order or product. A Currency 

data type is best for storing monetary values. To ensure that data in a fi eld supports 

searches or meets certain conditions, use a data type that supports a conditional 

expression, or Boolean operator, such as AND, OR, or NOT. One kind of Boolean 

operator is a comparison operator, such as equal, not equal, less than, more than, and 

so on. Common data types that support Boolean operators are shown in Table 1.2.

TABLE 1.2 Common Data Types that Support Boolean Operators 

Text Currency 

Number Yes/No

Date/Time AutoNumber

FIGURE 1.4 Product Info Stock field added to parts database

Data type drop-down arrow

Navigation pane

Product 
Info table

 Click Start>All 

Programs>Microsoft 

Office®>Microsoft 

Office Access 2007.

 Click Office . Click 

Open.

 Navigate to the Phil’s 

Pick-a-Part database fi le. 

Ask your teacher how and 

where to copy the database 

before working in it.

 Select the database fi le and 

click Open.

 In the Navigation Pane, 

right-click the Product Info 

table and select Design 

View from the menu.

 In the Field Name column, 

click in the blank cell under 

Cost. Key: QtyInStock. 

Press .

 Click the Data Type drop-

down arrow . From the 

list of data types, select 

Number.

Your screen 

should look like Figure 1.4.

 Under Field Properties, 

click in the Caption box 

and key: Stock Quantity.

 Click Save . Click the 

Cost fi eld and press . 

Change the Data Type to 

Currency.

Continued on the next page.
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Step-By-Step EXERCISE 2 (Continued)

Defi ne Field Data Types

FIGURE 1.5 Product Info Datasheet View

New field defined 
and added

FIGURE 1.6 Customer Info Design View

 Under Field Properties, 

click in the Format box. 

Choose Currency.

 Click Datasheet View . 

Click Yes to save changes. 

Click Yes again.

 Your screen 

should look like Figure 1.5. 

Close the Product Info

table.

 Open the Customer Info 

table in Design View.

 Click in the Notes fi eld 

Data Type box. Click the 

drop-down arrow and 

select Memo.

 Your screen 

should look like Figure 1.6.

 Click Save . Close the 

Customer Info table.

Continue to the next exercise.

The data types you assign 
will depend on how you 
want to use the data. A 
Date/Time data type 
stores dates. A Number 
data type performs 
calculations. The Memo 
data type saves notes. To 
ensure that data meets a 
condition, change a fi eld’s 
data type to support 
searches or comparisons. 
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Step-By-Step EXERCISE 3
Modify Field Properties
Access allows you to set and modify properties for entire tables and for individual 

fi elds within a table. For example, by specifying the Field Size, or maximum number 

of characters that a user can enter in a fi eld, you can ensure that data in the Phone 

Number fi eld contains ten digits. You also can set a memo fi eld as Append Only. With 

this option, users can add data to a fi eld, but they cannot delete data from it. Common 

properties for fi elds in a table are shown in Table 1.3.

TABLE 1.3 Common Field Properties 

Allow Zero Length
Specifi es that a Text, Memo, or Hyperlink fi eld can accept strings of 
zero length, or null values, with no characters.

Append Only
Specifi es that data can be added to a Memo fi eld, but that the existing 
data in the fi eld cannot be overwritten.

Caption Specifies the name of a Text field.

Field Size Specifi es the maximum number of characters a user can enter in a fi eld.

Required Specifi es that data must be entered in a fi eld.

FIGURE 1.7 Customer Info table edited

Customer Name field

Notes field

 In your Phil’s Pick-a-Part

database, in the Naviga-

tion Pane, double-click 

the Customer Info.

 Choose Home>Views>

Design View .

 Click the Customer Name 

fi eld. In Field Properties, 

click in the Field Size box. 

Key: 80. Press .

 Click the row selector to the 

left of Telephone. While 

still holding the mouse 

button, drag down until the 

bold black line is above the 

Description fi eld. 

 Release the mouse. Scroll 

down the fi eld names list 

and click in the Notes fi eld.

 Scroll down the Field 

Properties and click in the 

Append Only box.

 Click the drop-down arrow 

and select Yes.

 Your screen 

should look like Figure 1.7.

 Click Save . Close the 

table.

Continue to the next exercise.

Access assigns a default 
fi eld name if you do not 
enter a caption for a fi eld.

Advanced Access 5 Exercise 3

ADV_U03L1_880263_001-010.indd Page 5  4/21/08  3:33:02 PM user-s191ADV_U03L1_880263_001-010.indd Page 5  4/21/08  3:33:02 PM user-s191 /Volumes/ju108/MHGL119/MHGL119_indd%0/Unit 3/Lesson 1/Volumes/ju108/MHGL119/MHGL119_indd%0/Unit 3/Lesson 1



Step-By-Step EXERCISE 4
Set Validation Rules
You can use the Validation Rule property to restrict the type and amount of data users 

can enter into a fi eld by creating a Boolean (or conditional) expression in the 

Validation fi eld. Validation rules use conditional expressions to specify that the data 

meets certain criteria. You can use the Validation Text property to customize the error 

message that Access displays when data that is entered into a fi eld violates a validation 

rule. Validation messages should contain information about the invalid data and how 

to fi x the error. Examples of validation rules are shown on page 7 in Table 1.4.

FIGURE 1.8 Customer Info table validation added

FIGURE 1.9 Customer Info table in Database View

Validation rule Validation text

 In your Phil’s Pick-a-Part

fi le, in the Navigation 

Pane, double-click the 

Customer Info table.

 Choose Home>Views> 

Design View .

 Click in the Account Start 

Date fi eld box. Under 

Field Properties, click in 

the Validation Rule box 

and key: >=#01/01/2009#.

 Click in the Validation 

Text box and key: Date 

entered must be after 

January 1, 2009.

 Your screen 

should look like Figure 1.8.

 Choose Design>Views>

Datasheet View . 

Click Yes to save changes.

 Your screen 

should look like Figure 1.9.

 In the Data Integrity 

warning box, click Yes. 

Continued on the next page.

Advanced Access 6 Exercise 4

ADV_U03L1_880263_001-010.indd Page 6  4/21/08  3:33:07 PM user-s191ADV_U03L1_880263_001-010.indd Page 6  4/21/08  3:33:07 PM user-s191 /Volumes/ju108/MHGL119/MHGL119_indd%0/Unit 3/Lesson 1/Volumes/ju108/MHGL119/MHGL119_indd%0/Unit 3/Lesson 1



Step-By-Step EXERCISE 4 (Continued)

Set Validation Rules 

FIGURE 1.10 Validation error dialog box

Invalid start date

Validation error dialog box with validation text

TABLE 1.4 Sample Validation Rules 

Validation Rule Description of Rule

>0 Requires users to enter a positive value 

<100 Requires users to enter a value that is less than 100

>100 AND <1000 Requires users to enter a value between 100 and 1,000 

[EndDate]>=[StartDate]
Requires users to enter an ending date that occurs on or after a 
starting date

>=#01/01/2008# Requires users to enter a date on or after January 1, 2008

[RequiredDate]<=[OrderDate]+30
Requires users to enter a date that is no later than 30 days after 
the order date  

 Scroll to the right until you 

can see the Account 

Start Date fi eld.

 Click in the fi rst record 

under the heading.

 Highlight the year 2009 in 

the date and key: 2006.

 Press .

 Your screen 

should look like Figure 1.10.

 In the warning dialog box, 

click OK. Highlight the date 

and key: 2009.

 Press .

 Close the table.

Continue to the next exercise.

If you enter data into a fi eld 
that violates a validation 
rule, Access prevents you 
from moving to another 
fi eld until the problem is 
fi xed. The Validation Text 
property tells you how to 
fi x the error.
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Step-By-Step EXERCISE 5
Defi ne and Modify Primary Keys
A primary key is a fi eld that ensures that each record in a table is unique. By default, 

Access records in a table are sorted based on the primary key. In the Phil’s Pick-a-Part 

database, for example, the Customer ID acts as a unique identifi er for each customer 

in the database. You can identify each customer uniquely because no two customers 

have the same Customer ID number. A fi eld with the AutoNumber data type is often 

used as the primary key because the numbers assigned to the fi eld increase 

automatically with each new record. Characteristics of a good choice for a primary 

key are shown in Table 1.5.

FIGURE 1.11 Customer Info table Datasheet View

TABLE 1.5 Choosing a primary key

A good candidate for a primary key…

1. Is a value that uniquely identifi es each record in the table.

2. Is a field that is never empty. It always contains a value.

3. Is a value that does not change.

 In your Phil’s Pick-a-Part

database, open the 

Customer Info table in 

Design View.

 Click the record selector for 

the  Customer ID fi eld. 

Choose Design>Tools>

Primary Key .

 Click the record selector for 

the  Customer Name 

fi eld. Choose Design> 

Tools>Primary Key .

 Choose Design>Views>

Datasheet View .

 Click Yes to save the 

changes to the Customer 

Info table.

 Your screen 

should look like Figure 1.11.

 Choose Design>Views>

Design View .

 Click Save  and close 

the Customer Info table.

Continue to the next exercise.

Some database fi elds 
would not make a good 
choice for primary keys. 
For example, you may 
have more than one John 
Smith in the Name fi eld. 

Customer Name alphabetized as Primary Key

Customer ID out of sequence when no longer 
Primary Key
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Step-By-Step EXERCISE 6
Defi ne and Modify Multi-Field Primary Keys
A multi-fi eld primary key is a table with two or more fi elds defi ned as the primary 

key. A multi-fi eld key is used if a table has no single fi eld that is appropriate to serve 

as the primary key. Although a primary key should include as few fi elds as possible, 

if a table has no single fi eld with a set of unique values, two or more fi elds can be 

combined to create a unique value. In this exercise, the Product ID fi eld in the Product 

Info table is not a suitable primary key. Multiple primary keys are assigned to the 

Product Name and Cost fi elds to fi x this problem. Because there are no two products 

with the same name or price in the Phil’s Pick-a-Part database, the multiple primary 

keys assign a unique value to the relationship between these two fi elds.

FIGURE 1.12 Product Info table multiple primary keys

Two Primary Key fields selected

Primary key icon

FIGURE 1.13 Product Info table Datasheet View

Product Name now determines 
listing order

 In your Phil’s Pick-a-Part

database, open the 

Product Info table in 

Design View.

 Click the record selector for 

the  Product Name.

 Hold down the  key 

and click the record 

selector for Cost.

 Choose Design>Tools>

Primary Key .

 Your screen 

should look like Figure 1.12.

 Choose Design>Views>

Datasheet View . 

Click Yes.

 Your screen 

should look similar to 

Figure 1.13.

 Click Design View .

 Click the record selector for 

the Product ID fi eld. Click  

Primary Key .

 Click Close  on the 

Product Info table. Select 

Yes to save changes.

Continue to the next exercise.

A multi-fi eld primary key 
is also referred to as a 
composite key.
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Step-By-Step EXERCISE 7
Defi ne Tables in Databases
When you design a database, it should be structured correctly so that the data is 

accurate, easy to work with, and accommodates your needs. When you add new 

tables to any database, analyze your design for errors to see if your tables are 

normalized, or structured correctly without repeated groups of information. A well-

designed database typically contains 3NF tables. A 3NF table is a table that is 

normalized to the third order. This means that they comply with the fi rst three rules 

of normalization. The three rules to create a 3NF table are shown in Table 1.6. The 

rules of form build on the previous rules, so a Third Normal Form table complies 

with all the rules of the fi rst and second forms as well as the third form.

TABLE 1.6 Rules of normalization 

Rule Description of Rule

1NF
Each fi eld in database table contains a single value, and the table has no repeating groups of 
information

2NF
Each non-key field in the table must be dependent on the entire primary key (including multi-field 
primary keys)

3NF Each non-key fi eld in the table is dependent only on the primary key

FIGURE 1.14 New Sales Info table

Table saved as Sales Info

Default Primary Key field

 In your Phil’s Pick-a-Part

database, open the 

Customer Info table.

 Scroll to the right until you 

see the Account 

Manager fi eld. Read the 

Account Managers’ last 

names listed in the 

Customer Info table.

 Close the Customer Info 

table.

 Choose Create>Tables>

Table .

 Choose Datasheet> 

Views>Design View . 

In the Save As dialog box 

key: Sales Info. Click OK.

 Your screen 

should look like Figure 1.14.

 Key: Account Manager. 

Press .

Continued on the next page.
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Step-By-Step EXERCISE 7 (Continued) 

Defi ne Tables in Databases
 Click the Data Type drop-

down arrow and select 

Text. Press  twice.

 Key: First Name. Press 

.

 Set the Data Type to 

Text. Press  twice.

 Key: Cell Phone. Click in 

the fi eld below Cell 

Phone.

 Key: Employee Number. 

Press .

 Click the drop-down arrow 

and select Number. Press 

 twice.

 Key: Client. Press .

 Click the drop down arrow 

and select Text.

 Your screen 

should look like Figure 1.15.

 Choose Design>Views>

Datasheet View . In 

the dialog box, click Yes to 

save changes to the table.

 Key the information into 

the table as it is shown in 

Figure 1.16.

 Click Close  to close 

the Sales Info table. Click 

Yes to save changes to 

table layout, if necessary.

Continue to the next exercise.

FIGURE 1.15 Sales Info table 3NF fields Design View

FIGURE 1.16 Populated Sales Info table Datasheet View

All fields are dependent 
only on primary key

Data Type drop-down arrow

No repeating 
groups
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Step-By-Step EXERCISE 8
Create Tables Based on the 
Structure of Other Tables
Rather than using a table template, or taking the time to build a new table for your 

database using Design View or Datasheet View, you can use an existing table’s 

structure to create a new table. You can create a table by copying and pasting the 

structure of an existing table in the Navigation Pane. You can edit the table name 

using the Paste Table As dialog box.

FIGURE 1.17 Paste Table As dialog box

FIGURE 1.18 Table structure copied to Customer Contacts

 In your Phil’s Pick-a-

Part database, in the 

Navigation Pane, right-

click the Sales Info table 

and select Copy.

 Right-click in an open area 

of the Navigation Pane 

and select Paste.

 In the Paste Table As 

dialog box, click in the 

Table Name box. Key: 

Customer Contacts.

 Under Paste Options, 

select the Structure Only 

option.

 Your dialog 

box should look like 

Figure 1.17. Click OK.

 In the Navigation Pane, 

double-click the Customer 

Contacts table.

 Your screen 

should look like Figure 1.18. 

Close the table.

 In the Navigation Pane, 

right-click the Customer 

Contacts table. Select 

Rename.

 Key: Quick Customer 

Contacts. Press .

Continue to the next exercise.

Structure Only option

New Customer Contacts table

Structure from Sales Info table
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Step-By-Step EXERCISE 9
Create and Modify Queries
A query gathers data from one or more tables based on criteria. Queries allow you to 

retrieve and display information from tables so that you can edit the results. A query is 

made up of the fi elds and records you choose in the order you want. If two or more 

tables have fi elds with the same name, you must identify which table you want the query 

to draw from. The information you need to provide to run a query is:

1) the criteria that you want the data to meet.

2) the fi elds that you want to include.

3) the tables from which you will retrieve the data.

FIGURE 1.19 Simple Query Wizard

Query Wizard button

FIGURE 1.20 Simple Query Wizard with all table fields selected 

 In your Phil’s Pick-a-Part

fi le, choose Create> 

Other>Query Wizard 

(see Figure 1.19).

 In the New Query dialog 

box, make sure the Simple 

Query Wizard option is 

selected. Click OK.

 In the Simple Query 

Wizard dialog box, under 

Tables/Queries, click the 

drop-down arrow and 

select Table: Sales Info.

 Under Available Fields, 

click the double right arrow 

 to select all fi elds in 

the Sales Info table.

 Your dialog 

box should look like 

Figure 1.20.

 Click Next. Leave the 

Detail option selected and 

click Next.

 Do not change the title for 

your query. Click Finish.

Continued on the next page.

To view the results of a 
query, choose Design>
Results>Run or switch to 
Datasheet View.

All fields in 
table added
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Step-By-Step EXERCISE 9 (Continued)

Create and Modify Queries
 Choose Home>Views>

Design View .

 Your screen 

should look like Figure 1.21.

 Choose Design>Query 

Setup>Show Table .

 In the Show Table dialog 

box, select the Customer 

Info table and click Add.

 Click Add again.

 Your screen 

should look like Figure 1.22.

 Close the Show Table 

dialog box.

 Right-click the header of 

the Customer Info_1 table 

and select Remove Table.

Continued on the next page.

FIGURE 1.21 Sales Info Query Design View

FIGURE 1.22 Sales Info Query duplicate tables added

Duplicate Customer Info table

Asterisk field adds entire 
table to field list area

Field list area

Show field check box

Another way to add all the 
fi elds from a table to query 
is to open the query in 
Design View. Then, 
double-click the asterisk 
(*) at the top of the list of 
fi elds in the query.

If you try to close an 
unsaved query, Access 
will prompt you to save it.
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Step-By-Step EXERCISE 9 (Continued)

Create and Modify Queries
 In the Sales Info Query, 

click the Customer Info 

table. Scroll through the 

fi eld list and double-click 

the Account Manager 

fi eld.

 Scroll to the top of the 

Customer Info table and 

double-click the 

Customer Name fi eld.

 Choose Design>Results>

Datasheet View .

 Your screen 

should look like Figure 1.23.

 Click Design View .

 In the fi eld list area, under 

the Account Manager 

fi eld of the Customer Info 

table, uncheck the box in 

the Show fi eld.

 Click Datasheet View .

Your screen 

should look like Figure 1.24.

 Click Save . Close the 

Sales Info Query.

 Click Office  and select 

Close Database.

Continue to the next exercise.

FIGURE 1.23 Sales Info Query Datasheet View

FIGURE 1.24 Query with duplicate field drawn from single table

Same field from two different tables
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Step-By-Step EXERCISE 10
Open Databases
When you open a database in Access, by default it can still be opened and edited by 

others at the same time. This is called shared access. If you need to ensure that you are 

the only one who can open and make changes to the database, you can select the 

Open Exclusive option. That means that no one else can open or edit the database 

because you have exclusive access. Access also offers an Open Exclusive Read Only 

option so that you and other users can view the database at the same time but cannot 

edit it. This read-only mode is helpful in a multi-user environment if you want to 

view a fi le but want to avoid making any accidental changes.

 Click Office . Click 

Open.

 In the Open dialog box, 

navigate to where your 

Phil’s Pick-a-Part fi le is. 

Select the database fi le and 

click the Open drop-down 

arrow.

Your dialog 

box should look similar to 

Figure 1.25. Select Open 

Exclusive.

 Click Office  and 

select Close Database.

 Click Office  and 

select Open. Select the 

database fi le again and 

click the Open drop-down 

arrow.

 Select Open Exclusive 

Read-Only.

 Your screen 

should look like Figure 1.26.

 Click Office  and close 

the database.

Continue to the next exercise.

FIGURE 1.25 Open dialog box 

FIGURE 1.26 Database opened exclusive read-only

Open button drop-down menu

Press   +  to 
display the Open dialog 
box.

Database file selected

Read-Only message
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Step-By-Step EXERCISE 11
Format and Modify a Chart
Access offers many tools to present data, but often one of the easiest and most 

effective ways to present data is through the use of charts. Depending upon the type 

of data and your audience, the same data can be presented in several different chart 

formats. Access allows you to easily change the format and type of a chart to improve  

the presentation of your data.

 Click Office  and 

select Open.

 Select your Phil’s Pick-a-

Part database. Click Open.

 In the Navigation Pane, 

click the Navigation Bar. 

Under Filter By Group, 

select Forms.

 Double-click the All 

Orders Chart form.

 Your screen 

should look like Figure 1.27.

 Choose Design>Type>

Change Chart Type .

 In the Properties dialog 

box, on the Type tab in the 

left column, select Bar. 

Click the 3D Bar 

Clustered chart type (see 

Figure 1.28).

 Your screen 

should look like Figure 1.28.

 Click the largest graphed 

quantity on the chart (see 

Figure 1.28). In the 

Properties dialog box, 

click the Border/Fill tab.

 Under Fill, in the Fill Type 

box, select Gradient.

 Under the Border area, 

click the Border Color

drop-down arrow. Select 

White.

Continued on the next page.

FIGURE 1.27 All Orders Chart

FIGURE 1.28 Chart type to 3D Bar Clustered

Change Chart 
Type button

Navigation Bar

Properties dialog box

3D Bar Clustered

Click this bar

Chart background
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Step-By-Step EXERCISE 11 (Continued)

Format and Modify a Chart
 Click in an open area of the 

chart space to select the 

chart background.

 In the Properties box, 

under Fill, click the Color 

drop-down arrow and 

select MediumSeaGreen.

 In the Properties box, click 

the Show/Hide tab. Under 

Show by default, uncheck 

the Field buttons/drop 

zones option.

 Your screen 

should look similar to 

Figure 1.29.

 In the Properties box, click 

the General tab. Under 

Add, click Add Title .

 Click Chart Workspace 

Title in the chart window. 

In the Properties box, 

click the Format tab.

 In the Caption box, 

highlight the default text 

and key: Parts Purchases 

by Volume.

 Choose Design>Tools>

Property Sheet .

Your screen 

should look similar to 

Figure 1.30.

 Close the All Orders 

Chart.

Continue to the next exercise.

FIGURE 1.29 Changes to chart formatting

FIGURE 1.30 Title added to chart
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Step-By-Step EXERCISE 12
Import and Export Data
You can gather and present different types of information in Access by importing the 

data. You can import Excel fi les, XML Paper Specifi cation (XPS) fi les, and Access 

databases. In order to save fi les in XPS format, you must download and install 

Microsoft’s XPS add-in. You also can import data from ordinary text fi les, as long as 

the information is delimited. A delimited fi le is a fi le that uses delimiters, or separators, 

such as  semicolons, colons, or tabs to separate information. An example of a 

delimited fi le is a comma-separated values (CSV) fi le. Access allows you to export data 

in a database fi le to many different fi les, programs, or databases. 

 In your Phil’s Pick-a-Part

database, in the Navigation 

Pane, show Tables.

 Choose External Data>

Import>Text File .

 Select the Append a copy 

of the records to the 

table: option. Click the 

drop-down arrow. Select 

the Quick Customer 

Contacts table.

 Your screen 

should look similar to 

Figure 1.31.

 Click the Browse button. 

In the File Open dialog 

box, select the Customer 

Contacts fi le. Click Open.

 In the Get External Data – 

Text File dialog box, click 

OK. Click Next twice. Click 

Finish. Click Close.

 Double-click the Quick 

Customer Contacts 

table.

Your screen 

should look like Figure 1.32.

Continued on the next page.

FIGURE 1.31 Importing a CSV file

FIGURE 1.32 CSV data imported into Quick Customer Contacts

 If there is no Save As>XPS 
option in your Offi ce menu, 
you must install the XPS 
add-in. 

Text File 
import button

Append a 
copy option

Data from CSV file entered into empty table

Advanced Access 19 Exercise 12

ADV_U03L1_880263_011-020.indd Page 19  4/21/08  3:34:08 PM user-s191ADV_U03L1_880263_011-020.indd Page 19  4/21/08  3:34:08 PM user-s191 /Volumes/ju108/MHGL119/MHGL119_indd%0/Unit 3/Lesson 1/Volumes/ju108/MHGL119/MHGL119_indd%0/Unit 3/Lesson 1



Step-By-Step EXERCISE 12 (Continued)

Import and Export Data
 Close the Quick 

Customer Contacts 

table.

 Open the Customer Info 

table and scroll to the last 

column on the right.

 In the Attachment fi eld, in 

the fi rst record, double-

click the attachment (see 

Figure 1.33).

 Your screen 

should look like Figure 1.33.

 In the Attachments 

dialog box, select the listed 

attachment and click 

Save As.

 Save the attachment in the 

location specifi ed by your 

teacher. Click OK.

 Choose Office >Save 

As>XPS (see Figure 1.34).

Continued on the next page.

FIGURE 1.33 Customer Info table attachment

FIGURE 1.34 Saving as XPS file

To export an attachment 
to a record in a database 
table, use the Save As 
command.

Attachment field

Publish as XPS option

If you want to keep a fi le in 
its original format, you can 
link to it or attach the fi le to 
the database. 

Double-click 
attachment

First record 
attachment
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Step-By-Step EXERCISE 12  (Continued)

Import and Export Data

FIGURE 1.35 Publish as XPS file dialog box 

Saving Customer Info as XPS

Document displayed in Internet Explorer

 In the Publish as XPS

dialog box, navigate to the 

location given by your 

teacher. 

 Select the Open file 

after publishing 

option and click Publish 

(see Figure 1.35).

Your screen 

should look like Figure 1.36.

 Close the application 

displaying the XPS 

document.

 Close the Customer Info 

table.

Continue to the next exercise.

Publish button

FIGURE 1.36 Published XPS fileTo save or publish a data-
base object as an XPS 
document or PDF fi le, 
choose External Data> 
Export>PDF or XPS. To 
save or publish a copy of 
the database object as a 
PDF or XPS fi le, choose 
Offi ce>Save As>PDF 
or XPS.

Open file option
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Step-By-Step EXERCISE 13
Set Printing Options
Sometimes you might want to make sure that the data in a report is kept together to 

avoid excess pages and to improve the overall appearance of the report. Print Preview 

lets you review each page and helps you make sure that text and fi elds are correctly 

placed and formatted. Layout View allows you to manipulate fi elds and groups, but 

it does not show page breaks or certain other elements. Access also lets you use the 

Keep Groups Together property to keep data together so that a portion of a record 

does not display on one printed page with the remainder on the next. You can use the 

Force New Page property to print a section of data on a separate page.

FIGURE 1.37 All Orders report Layout View

FIGURE 1.38 All Orders report Print Preview

 In your Phil’s Pick-a-Part

database, in the Navigation 

Pane, click the Navigation 

Bar and select Reports.

 Open the All Orders 

report.

 Choose Home>Views>

Layout View .

 Scroll to the end of the 

report.

 Your screen 

should look like Figure 1.37.

 Select Format>Views and 

click the View drop-down 

arrow. Select Print 

Preview .

 Choose the Print 

Preview>Zoom>Two 

Pages .

 Your screen 

should look like Figure 1.38.

Continued on the next page.

You can also right-click an 
open area of the report 
window to select Print 
Preview.

Layout View shows fit on one page

View drop-
down arrow

Broken grouping over two pages

Close Print Preview

Print Preview shows 
two pages at a time
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Step-By-Step EXERCISE 13 (Continued)

Set Printing Options 
 Click Close Print 

Preview . Choose 

Home>Views>Layout 

View .

 Choose Arrange>Tools>

Property Sheet .

 In the Property Sheet, 

under Selection Type, 

click the drop-down arrow. 

Select Detail. On the 

Format tab, click the 

Force New Page box. 

Select After Section.

 Right-click in an open area 

of the report window and 

select Print Preview .

 Your screen 

should look like Figure 1.39. 

Close Print Preview.

 In the Property Sheet, 

under Selection type, 

click the drop-down arrow. 

Select Detail. Click in the 

Force New Page box. 

Select None.

 Close the Property 

Sheet.

 Choose Format>

Grouping & Totals>

Group & Sort .

Your screen 

should look like Figure 1.40.

Continued on the next page.

FIGURE 1.39 All Orders report with Force New Page After Section

Sections broken onto individual pages

FIGURE 1.40 Grouping and Sorting window

Group & Sort button

Click to expand options

Sorting window
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Step-By-Step EXERCISE 13 (Continued)

Set Printing Options
FIGURE 1.41 Grouping sections together on same page

Groups are kept on same p age

FIGURE 1.42 All Orders report grouped in sections Print Preview

 In the Group, Sort, and 

Total window on the 

Group on Customer 

Name bar, click More.

 Click the do not keep 

group together on one 

page drop-down arrow 

and select keep whole 

group together on one 

page.

 Your screen 

should look like Figure 1.41.

 Choose Format> 

Grouping & Totals> 

Group & Sort  to close 

the window.

 Choose Format>Views>

View>Print Preview .

 Your screen 

should look like Figure 1.42.

 Close the report. In the 

dialog box, click Yes to 

save changes.

 Close your database. Exit 

Access.

Groups are not broken over pages

Advanced Access 24 Exercise 13

ADV_U03L1_880263_021-024.indd Page 24  4/21/08  3:34:38 PM user-s191ADV_U03L1_880263_021-024.indd Page 24  4/21/08  3:34:38 PM user-s191 /Volumes/ju108/MHGL119/MHGL119_indd%0/Unit 3/Lesson 1/Volumes/ju108/MHGL119/MHGL119_indd%0/Unit 3/Lesson 1


	u3fm.adv.pdf
	u3l1.adv.pdf
	ADV_U03L1_880263_001-010.pdf
	ADV_U03L1_880263_011-020.pdf
	ADV_U03L1_880263_021-024.pdf



<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /None
  /Binding /Left
  /CalGrayProfile (Dot Gain 20%)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Error
  /CompatibilityLevel 1.4
  /CompressObjects /Off
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages false
  /CreateJDFFile false
  /CreateJobTicket true
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /DetectCurves 0.0000
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedOpenType false
  /ParseICCProfilesInComments true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo false
  /PreserveCopyPage true
  /PreserveDICMYKValues true
  /PreserveEPSInfo true
  /PreserveFlatness true
  /PreserveHalftoneInfo true
  /PreserveOPIComments false
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts false
  /TransferFunctionInfo /Preserve
  /UCRandBGInfo /Preserve
  /UsePrologue false
  /ColorSettingsFile (None)
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /CropColorImages true
  /ColorImageMinResolution 300
  /ColorImageMinResolutionPolicy /OK
  /DownsampleColorImages true
  /ColorImageDownsampleType /Average
  /ColorImageResolution 150
  /ColorImageDepth -1
  /ColorImageMinDownsampleDepth 1
  /ColorImageDownsampleThreshold 1.00000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 1.30
    /HSamples [2 1 1 2] /VSamples [2 1 1 2]
  >>
  /ColorImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasGrayImages false
  /CropGrayImages true
  /GrayImageMinResolution 300
  /GrayImageMinResolutionPolicy /OK
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Average
  /GrayImageResolution 150
  /GrayImageDepth -1
  /GrayImageMinDownsampleDepth 2
  /GrayImageDownsampleThreshold 1.00000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 1.30
    /HSamples [2 1 1 2] /VSamples [2 1 1 2]
  >>
  /GrayImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasMonoImages false
  /CropMonoImages true
  /MonoImageMinResolution 1200
  /MonoImageMinResolutionPolicy /OK
  /DownsampleMonoImages false
  /MonoImageDownsampleType /Average
  /MonoImageResolution 1200
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects true
  /CheckCompliance [
    /None
  ]
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile (None)
  /PDFXOutputConditionIdentifier ()
  /PDFXOutputCondition ()
  /PDFXRegistryName ()
  /PDFXTrapped /False

  /Description <<
    /CHS <FEFF4f7f75288fd94e9b8bbe5b9a521b5efa7684002000410064006f006200650020005000440046002065876863900275284e8e9ad88d2891cf76845370524d53705237300260a853ef4ee54f7f75280020004100630072006f0062006100740020548c002000410064006f00620065002000520065006100640065007200200035002e003000204ee553ca66f49ad87248672c676562535f00521b5efa768400200050004400460020658768633002>
    /CHT <FEFF4f7f752890194e9b8a2d7f6e5efa7acb7684002000410064006f006200650020005000440046002065874ef69069752865bc9ad854c18cea76845370524d5370523786557406300260a853ef4ee54f7f75280020004100630072006f0062006100740020548c002000410064006f00620065002000520065006100640065007200200035002e003000204ee553ca66f49ad87248672c4f86958b555f5df25efa7acb76840020005000440046002065874ef63002>
    /DAN <>
    /DEU <>
    /ESP <>
    /FRA <>
    /ITA <>
    /JPN <FEFF9ad854c18cea306a30d730ea30d730ec30b951fa529b7528002000410064006f0062006500200050004400460020658766f8306e4f5c6210306b4f7f75283057307e305930023053306e8a2d5b9a30674f5c62103055308c305f0020005000440046002030d530a130a430eb306f3001004100630072006f0062006100740020304a30883073002000410064006f00620065002000520065006100640065007200200035002e003000204ee5964d3067958b304f30533068304c3067304d307e305930023053306e8a2d5b9a306b306f30d530a930f330c8306e57cb30818fbc307f304c5fc59808306730593002>
    /KOR <FEFFc7740020c124c815c7440020c0acc6a9d558c5ec0020ace0d488c9c80020c2dcd5d80020c778c1c4c5d00020ac00c7a50020c801d569d55c002000410064006f0062006500200050004400460020bb38c11cb97c0020c791c131d569b2c8b2e4002e0020c774b807ac8c0020c791c131b41c00200050004400460020bb38c11cb2940020004100630072006f0062006100740020bc0f002000410064006f00620065002000520065006100640065007200200035002e00300020c774c0c1c5d0c11c0020c5f40020c2180020c788c2b5b2c8b2e4002e>
    /NLD (Gebruik deze instellingen om Adobe PDF-documenten te maken die zijn geoptimaliseerd voor prepress-afdrukken van hoge kwaliteit. De gemaakte PDF-documenten kunnen worden geopend met Acrobat en Adobe Reader 5.0 en hoger.)
    /NOR <>
    /PTB <>
    /SUO <>
    /SVE <>
    /ENU (Use these settings to create Adobe PDF documents best suited for high-quality prepress printing.  Created PDF documents can be opened with Acrobat and Adobe Reader 5.0 and later.)
  >>
  /Namespace [
    (Adobe)
    (Common)
    (1.0)
  ]
  /OtherNamespaces [
    <<
      /AsReaderSpreads false
      /CropImagesToFrames true
      /ErrorControl /WarnAndContinue
      /FlattenerIgnoreSpreadOverrides false
      /IncludeGuidesGrids false
      /IncludeNonPrinting false
      /IncludeSlug false
      /Namespace [
        (Adobe)
        (InDesign)
        (4.0)
      ]
      /OmitPlacedBitmaps false
      /OmitPlacedEPS false
      /OmitPlacedPDF false
      /SimulateOverprint /Legacy
    >>
    <<
      /AddBleedMarks false
      /AddColorBars false
      /AddCropMarks false
      /AddPageInfo false
      /AddRegMarks false
      /ConvertColors /ConvertToCMYK
      /DestinationProfileName ()
      /DestinationProfileSelector /DocumentCMYK
      /Downsample16BitImages true
      /FlattenerPreset <<
        /PresetSelector /MediumResolution
      >>
      /FormElements false
      /GenerateStructure false
      /IncludeBookmarks false
      /IncludeHyperlinks false
      /IncludeInteractive false
      /IncludeLayers false
      /IncludeProfiles false
      /MultimediaHandling /UseObjectSettings
      /Namespace [
        (Adobe)
        (CreativeSuite)
        (2.0)
      ]
      /PDFXOutputIntentProfileSelector /DocumentCMYK
      /PreserveEditing true
      /UntaggedCMYKHandling /LeaveUntagged
      /UntaggedRGBHandling /UseDocumentProfile
      /UseDocumentBleed false
    >>
  ]
>> setdistillerparams
<<
  /HWResolution [72 72]
  /PageSize [792.000 1224.000]
>> setpagedevice




